Powered by Jitbit AspNetForum free trial version.
home recent topics recent posts search register faq   AspNetForum v.4.7.5.0

Whistling Fish Software :: Forum

user:
psw:
| lost password
Home » Luthier's Workbench Support » Net Framework problem preventing installation Messages in this topic - RSS
14/08/2012 9:04:13 PM
ash
Posts 2
Howdy,

I'm trying to install Luthier's Workbench, but it says "your system lacks the following pre-requisites required to install Luthiers Workbench - Microsoft .NET Framework 4.0"

Problem is, I already have NET 4 installed - version v4.0.30319

The LW installer doesn't want to install or update NET itself, it asks me to do it manually via Windows Update. Win Update offers "repair current installation or remove current installation". Removal is blocked and I've done the repair thing twice and rebooted, but LW still can't see it.

What next?
26/08/2012 12:59:20 PM
admin
admin
Posts 26
Hi Ash

I haven't encountered this before and no-one has reported the problem previously.

Just guessing, but the fact that the installer is asking you to install the .NET Framework manually suggests to me that there's some security setting on your system preventing automatic updates. Ordinarily, the Luthier's Workbench installer will download and install prerequisites automatically.

1. What operating system are you running?
2. Is the OS 32-bit or 64-bit?

Cheers
Pete
26/08/2012 1:22:21 PM
ash
Posts 2
Windows 7 64bit

thanks.
26/08/2012 3:47:21 PM
admin
admin
Posts 26
Hi Ash

I double-checked the installation of Luthier's Workbench on 64-bit Windows 7 and had no problem setting it up.

Luthier's Workbench is explicitly compiled as a 32-bit application for backwards compatibility. As such, on 64-bit operating systems, it should be installed in the default location for 32-bit apps, i.e, c:\Program Files (x86). Make sure you've accepted this default path when you proceed through the installation process.

The .NET Framework will handle calls from both 32-bit and 64-bit applications - there's no need to install a separate 32-bit version. The version number I have installed is the same as your own.

If removal and/or repair of the .NET Framework is blocked by your computer, I think it's safe to conclude that the problem lies with the configuration of your computer's security settings rather than Luthier's Workbench itself.

I hope you can sort this out Ash. Please let me know how it goes.


Cheers
Pete
11/10/2012 3:27:24 AM
Tinker Guitars
Posts 1
I tried installing LW on my 64bit Windows computer last night and had the same problem as ash. I manually installed network 4 twice, rebooted etc., but the wizard still won't install LW. Can you suggest specifically what may be the problem in security settings? I'm running avg, would that be a problem?
13/11/2012 12:52:12 AM
WhistlingFish
WhistlingFish
Posts 87
Ed,

Please accept my apologies for not responding sooner. I am about to complete my first semester at university and I've found it necessary to neglect almost everything else over the past three months. I will have exams out of the way very soon and will attend to all the outstanding requests as soon as I can.

Cheers
Pete
pages: 1
|

Home » Luthier's Workbench Support » Net Framework problem preventing installation